Win10 Client Install Failing

One of my end users is running Win10 (up to date) and had a previous version of the Client Software installed (about 3 generations back). This particular end user does not use the system often. While off-site he attempted to connect the client software and, the client software being out of date, it did not connect. The software was not giving the option to update (the task bar icon was not giving options and would only want to show the initial connection screen.) After attempting a manual update (remove old version/reboot/install new version) the New version install is failing and Rolling Back. The TAP seems to install and the network Adapter for the TAP shows up but the rest of the application is MIA. Cannot connect or even get the software to run. With no application there are no TwinGate logs but I did pull the information from the eventvwr.

Error 1 from eventvwr Windows>Applications
Faulting application name: Twingate.Service.exe, version: 1.0.30.22347, time stamp: 0x895eb290
Faulting module name: KERNELBASE.dll, version: 10.0.19041.3570, time stamp: 0xda674bb7
Exception code: 0xe0434352
Fault offset: 0x000000000002cf19
Faulting process id: 0x4470
Faulting application start time: 0x01da0b321119c7ce
Faulting application path: C:\Program Files (x86)\Twingate\Twingate.Service.exe
Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll
Report Id: b1157830-e602-44a3-a9b4-4760a21b4cb9
Faulting package full name:
Faulting package-relative application ID:

Error 2 from Eventvwr Windows>Applications
Application: Twingate.Service.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: Twingate.Client.Common.Windows.DeviceDetails.MachineIdGenerationException
at Twingate.Client.Common.Windows.DeviceDetails.ComputerIdProvider.GetMachineGuid()
at Twingate.Client.Common.Windows.DeviceDetails.ComputerIdProvider.GetId()
at Twingate.Client.WinService.Program.Main(System.String

Informational 1 from Windows>Applications
Windows Installer installed the product. Product Name: Twingate 1.0.30+22347. Product Version: 1.0.30.22347. Product Language: 1033. Manufacturer: Twingate Inc… Installation success or error status: 1603.

Informational 2 from Windows>Applications
Log Name: Application
Source: MsiInstaller
Date: 10/30/2023 9:08:06 AM
Event ID: 11708
Task Category: None
Level: Information
Keywords: Classic
User: DESKTOP-$$$$$$$\EndUser
Computer: DESKTOP-$$$$$$$
Description:
Product: Twingate 1.0.30+22347 – Installation failed.
Event Xml:



11708
0
4
0
0
0x80000000000000

151315


Application
DESKTOP-6HRMUP1



Product: Twingate 1.0.30+22347 – Installation failed.
(NULL)
(NULL)
(NULL)
(NULL)
(NULL)


7B31314241334234352D443846412D343532342D413038352D3830464231413744453344387D

Hi, did you retry the install with a more recent version of the Twingate Client?

also, long shot but… does the host name of the machine happen to start with a ‘-’?

I did. I tried ripping and replacing it a couple of times with 3 different versions…from the 1st one that I installed to the newest one. and no it does not though it does have a ‘-’ in it

are you installing the Client using the MSI or EXE version of the installer?

I was using the EXE. Didn’t think about the MSI though I can certainly try it.

The EXE is the right one to use if you are not deploying the Client with a MDM actually (because it embeds the dependency on .NET 6, the MSI does not but the dependency gets fulfilled by the MDM).

Would you check if .NET 6 is installed on the user’s system actually?

just got access to the endpoint again…net 6.0.14 is installed and I did try the MSI…it got to the same point and then rolled back again.
TG_Install_Fail

So as a test I went through and ripped .NET 6 off as well and ran the EXE again to reinstall everything. I did catch a different informational grouped up with the errors this time after the installer failed. it was labeled as a ‘Windows Error Report’ with a code of 1001.

Fault bucket 1742993475164227666, type 4
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: Twingate.Service.exe
P2: 2023.292.9388.0
P3: 64e81669
P4: KERNELBASE.dll
P5: 10.0.19041.3570
P6: da674bb7
P7: e0434352
P8: 000000000002cf19
P9:
P10:

Attached files:
\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERA148.tmp.dmp
\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERA1E6.tmp.WERInternalMetadata.xml
\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERA1F6.tmp.xml
\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERA204.tmp.csv
\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERA224.tmp.txt

These files may be available here:
\?\C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppCrash_Twingate.Service_f9c5efb43cf88a5ad56ad8b1daef76af2669ba7_78e38193_cd16c396-9056-435f-8dfe-995bb26af0dd

Analysis symbol:
Rechecking for solution: 0
Report Id: 21af503c-4963-4fb1-984d-364126875e76
Report Status: 268435456
Hashed bucket: eea297a3f79a507558305b54b4fcc852
Cab Guid: 0

Hi @KStehman,

do you see the Twingate Network Adapter in the list of network adapters on the machine in question?

yes, it is installing the network adapter…it seems to be failing during the service install

Hi @KStehman, ok good to know. This isn’t a known issue on the Twingate Client side, usually the service failing to install is due to permission issues.

Looking at our records, the only similar error message I see is from 3 months ago and happened due to a device with no serial number assigned but it has been fixed since. Just to confirm again, you are trying to install version 2023.292, correct?

Correct. I went to the website and grabbed a fresh copy of the EXE just to be sure I had the latest version. The MSI did give me the same results.

I am getting the same problem. I used both .exe and .msi. I upgraded all my Microsoft software and also rebooted machine. all I get is this: (I extracted text from image)

Twingate 2023.318.428 Setup

Twingate 2023.318.428 Setup Wizard ended prematurely
Twingate 2023.318.428 Setup Wizard ended prematurely because of an error. Your system has not been modified. To install this program at a later time, run Setup Wizard again.
Click the Finish button to exit the Setup Wizard.

UPDATE I also reinstalled .NET latest version and rebooted again. I’m getting frustrated.

hi @CharlesG,

could you try the steps mentioned in this forum post?

I’ll do this Wednesday

I’ve tried this and i still get get it to work.

I followed all the steps in that thread. I go the same results, no install with both msi and exe. I have no 3rd part anti-virus. I also uninstalled TAP-Twingate and renamed c:\program files\twingate\ that had a bunch of .tmp files that I couldn’t delete. I have no more time for this and I’m moving on.

Hi @CharlesG, I wonder if you have the right local privileges (strange that you couldnt delete some of the tmp files). Could that be it or are you local admin? Very sorry you weren’t able to make it work so far.

I opened a cmd “box” as admin. And it said no access. I renamed the folder as a work around.

Hello Guys,

I was also facing the same problem.

  1. Uninstall the Client

  2. Open regedit and review entries in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList\Profiles and look for any Twingate Profiles, and delete them

  3. Open CMD As Administrator, and run: mofcomp %windir%\system32\wbem\cimwin32.mof

  4. Uninstall ‘TAP windows twingate’ from control panel because even if entire twingate is not able to be installed, it does install this network adapter app.

  5. Restarted the pc.

Tried above steps several times but failed.

But then after following these steps, I did following :

  1. Installed CCleaner
  2. Ran It
  3. Restart PC
  4. Boom, Finally Twingate installation was successful. (FYI, I used exe latest version)

Premature ending of certain application is general error which can be caused by any windows .NET based applications. There are certain residuals which you can’t remove manually. It’s easy to use app lik CCleaner which does a better job of cleaning the residuals.

Windows 11 (latest update)

1 Like