Twingate installation Fails

Hi Everyone,

am running into an issue during the installation of twingate, the installation fails and rolls back all the changes and i get this message: your system has not been modified.

i checked on the logs and this is what i got:
[2024-02-21T16:22:30.921558+04:00] [DEBUG] [client] SentryClient.IsEnabled = True [SentryClient.set_IsEnabled]
[2024-02-21T16:22:31.086891+04:00] [DEBUG] [client] SentryClient. Add Nlog configuration [SentryClient.UpdateLoggerConfig]
[2024-02-21T16:22:31.408537+04:00] [INFO] [client] Environment Information:
Current User: EGDXB-061$
Machine name: EGDXB-061
OS version: Microsoft Windows NT 10.0.22631.0
OS Is64Bit: True [EnvironmentInfo.LogEnvironmentReport]
[2024-02-21T16:22:31.762096+04:00] [DEBUG] [client] Start service posture data collection. [DevicePostureDataProvider.GenerateServiceData]
[2024-02-21T16:22:31.910529+04:00] [DEBUG] [client] Service startup args: C:\Program Files\Twingate\Twingate.Service.dll --reset [Service.ParseCommandLine]
[2024-02-21T16:22:31.929459+04:00] [WARN] [client] Posture check failed. Use the fallback value. COMException: The service has not been started. (0x80070426) [BasePostureFallbackCheck1.Run] [2024-02-21T16:22:32.110663+04:00] [DEBUG] [client] Settings are saved. [AppSettingsBase1.Save]
[2024-02-21T16:22:32.119199+04:00] [DEBUG] [client] Reset Service Settings [Service.ConfigureApplication]
[2024-02-21T16:22:32.119199+04:00] [DEBUG] [client] Settings are reset. [AppSettingsBase`1.Reset]
[2024-02-21T16:22:34.693516+04:00] [INFO] [client] Saving Service as key net.tcp:// [Service.SaveEndpointToRegistry]

I tried to remove everything the temp files, twingate files that was still there, restarted the device and tried to reinstall it again but i got the same result.
could you please help me out.

Thanks and Regards,

Hi @Ahmed,

Check the Windows Event Viewer logs as well in this case, the installation process gets logged there. It looks like there’s maybe a missing or corrupt dependency (such as .NET 6), but there should be an error in the Applications log section if you search for Twingate (probably under the MsiInstaller process).