Windows Network Mapped Drives issue


I recently installed and setup Twingate via docker and connected to my Active directory using the Azure method. Everything seems to be moving nicely until I had to connect a few remote devices to my windows network shared/mapped drives. I cannot open my existing shared folders inside after creating the necessary resources and authentication to open those shared drives. I get error messages similar to as if I am not connecting via VPN. The devices are part of a domain AD and once logged in they require remote devices to connect to a VPN to open these shared mapped drives.

I cannot locate any useful forum discussing how to fix this issue. I can RDP using any IP address to specific servers, but I was hoping for a straightforward solution how to open existing mapped drives without modification to them.

Below is an example of what I am trying to open, this shows the drives as mapped and working since they are on my internal network but shows red on the icon on any remote device trying to connect.

Any advice or direction that could point me to the right direction would be appreciated.

In this instance, if you attempt to connect to one of those shared drives manually (ie open \\\sharedfolder in Windows explorer or via start > run, does it let you open it at that point, or still fail?

I have not tried remapping the drives but the ones that currently are connected to each remote device it gives me an error stating the connection Is already in use. The same occurs if no VPN is present yet I believe everything is correctly setup.

But if you try to just open \\sharpe-file1\shared (not Map it, just open it in Explorer) while connected to Twingate does it work?

When I type in IP address to server in file explorer or CMD method it works but when I try to open via \sharpe-file1\shared it cannot find it in the server path which is odd. As you mentioned in your previous replay, I can open it using IP but we use this particular network drive which hosts our data with our ERP software. it will launch and cause issues as if it cannot read the IP address its located from.

Right now, I was able to communicate by creating a network folder, but I was hoping I could assign it to a driver letter without issues since our ERP is trying to pull from a network drive letter.


Do you have local HOSTS file entries defined for sharpe-file1 etc? Right now you only have Twingate resources defined for the IP addresses of those servers, so there’s no way Twingate can handle traffic trying to speak to those devices via unqualified hostname.

You would need to add Twingate resources for all the UQDNs you want to access.

Would I have to install a twingate installer on the servers directly? I do not have connection failures with authentication communicating through my resources inside the twingate portal. It looks like everything is working but for some reason it is still drawing from the IP over the name of the server for this particular shared folder. The file1 and UPS network folder’s function and appear to be correct.

In my particular case the folder is opening, and I can view the contents but when I launch a program now from that APPS network folder it gives an IP over the path name which the program tries to communicate from. I deleted all cache/temp and prefetch and the issue still occurs.

Normally this path is \Sharpe-apps1\APPS\Global\Plugins\Login\GSSMenu.exe
The photo below shows the IP over the name of the server path.

Thank you for your assistance.

Nope, you wouldn’t need to install a connector on each server, but right now you have a Twingate resource for but NOT Sharpe-apps, which means if Windows tries to contact \\Sharpe-Apps Twingate has no idea it’s supposed to intercept/route that traffic.

So in addition to all the various IPs of the servers, you’ll also want to add resources for all of the short names of the servers too.

We are having a similar issue. We have a program that maps our network drives using net use. It will attempt to ping the server/resource before mapping it, but these pings seem to be failing, so the drives will not map.
When we ping the server from command prompt manually, it will not respond either. But we can manually type in the address of the server in file explorer and go to it fine.

Is there any way to change it to connect via servername over IP? in my particular situation our network drive needs to communicate over servername rather than IP.

Either in file explorer or Mapping the path it cannot locate \Sharpe-APP1\Global. The database will not accept anything but this server name even though I can open the files using the IP address.

Every tutorial shows using connectors and resources via ip address but when I type in this particular servername in a resource it does not work.

Hey Leo,

It looks like you were able to get a resource created for sharpe-apps1 - are you still having issues connecting? If you run nslookup sharpe-apps1 from a command prompt, what comes back?

When I run nslookup sharpe-apps1 it gives me this response yet the dns is correct and this server is connected to that domain. Server is unknown but it gives me an address.


I was able to fix the issue, now everything seems to be communicating properly with our network drives and was able to remap it to server name rather than IP. Once I remoted RDP to my server everything seemed to be working as if it needed a direct line connection to communicate with the resources it was trying to connect to. The DNS was not responding either.

Thank you for your swift response and help.


Revisiting this Thread,

Hello Arthur,

I have a network drive mapped that refused to stay connected for long, when I initially run a program through that server name drive it will work but as soon as I either restart or the device goes to sleep it has to be authenticated again through Microsoft domain controller side using admin username/Password. (I also authenticate through the twingate portal which states it is connected)

The other 2 network drives connected from the same network server work with no issue but for some reason no matter which remote computer device I run this particular drive it repeats with the same cannot find drive error.

I am a bit stuck on what is causing this from twingate side. My other older VPN connects to those drives, so I know it not caused by the DC side.

Any ideas what to check?

Thank you