Everything says connected but unable to reach home network from phone

I recently installed Twingate on my home laptop using docker. In the admin console on the laptop and the app on my android phone, it says connected. When I try to access my home computer from my phone it doesn’t work. Im not entirely sure what is supposed to happen, but my phone stays on the Twingate app showing the green connected dots. Any help is appreciated.

Hi JP,

Do you mean that you just see “Twingate” and then a list of your defined resources with green dots?

If this is the case, you can leave the Twingate app, and you would need to download a remote desktop app for your phone, and use that to connect to your home computer via it’s local IP address or hostname (whichever you have defined as Twingate resources).



Thanks, the remote desktop app must be what I am missing. I didn’t realize I needed that. Is there one that works better than another with Twingate?

There should be no difference in performance regardless of which app you use. Microsoft makes one for both iOS and Android and that’s what I use myself.

So I tried multiple remote desktop apps and that didn’t help. The steps I took were to log into the Twingates app on my phone. Then I open the remote desktop app on the phone and enter the IP address that I have in the specific resource I want to access. My understanding is that if I have the IP address of my laptop I will be able to access the computer? As a side note I noticed the IP address listed under the command prompt is different than the one I am seeing when looking under ubuntu with ifconfig?

I’m experiencing a similar issue.
I show to have active connectors, and resources (all green in the console), no port or policy restrictions or authentication issues, and yet I cannot connect to any resource (SMB NAS or RDP) from either a Ubuntu laptop or Android phone.

I figured out my issue.
It was that I had a client also running on the computer that hosts the connector.
Once I shutdown the client, everything worked.

I’m glad to see that you figured it out. Honestly I gave up trying to figure it out on my end because I was getting too frustrated. I ended up setting up a tunnel through ngrok that has worked pretty well. I wouldn’t mind revisiting the twin gate thing to see if it would work for me. When you say you had a client running on your computer you’re trying to connect to. What do you mean and how would I know if that was my issue?