DNS resolution fails with other VPN while inactive Twingate Client (Windows)

Hi there,

I do some freelance work, so I have different clients. To access resources at client A I use Twingate and I really like it. I have the Windows Twingate client installed on my local machine. But the twingate client is causing problems with my access to the resources of customer B. When I work remotely for customer B, I stop the twingate client and start using the classic VPN client provided by them. Although I stopped the twingate client, the name resolution of client B’s local domain names does not work and the Twingate client causes some strange behavior of nslookup. All requested resolutions with nslookup result in a DNS lookup timeout. If I uninstall the Twingate client, the domain name resolution works when connected to customer B’s VPN. Also nslookup behaves normally.

Is there a way to temporarily disable twingate so I don’t have to uninstall it every time I work for client B?


Are you choosing “Log Out & Disconnect” rather than just “Quit”? “Quit” will kill the “front end” of Twingate but leave the service running in the background. “Log Out & Disconnect” should stop all rogue DNS interception accordingly.

1 Like

Hi @jonaschu,

when shutting down the Twingate Client in Windows, make sure to click the “Log out & disconnect” option and not the “Quit” option.

The reason:

the Quit button shuts off the UI component of the Client but does NOT stop the underlying Twingate Service (which effectively means that your Twingate Client is still live).

the Log out & disconnect button does shut off the Twingate Service.

1 Like

Thanks guys! @Bren @Arthur

You are absolutely right, now it works. If the client is still running in the background, why is the icon showing or not showing in the taskbar? It makes little sense from a usability perspective. I understood the icon as an indicator of whether the Twingate client is active or not.