Cannot start the linux client

I am currently trying to get the linux client to run but whenever i try to do so it fails.

The error message reads:

  • Execution returned an error code with the message: Unexpected directory owner
  • Execution returned an error code with the message: twingate service-start failed

This happens whenever I try to setup the client or just the regular start.

For context I’m using Arch.

1 Like

I have the same issue. any ideas @alexb

Could you share the commands you’re using to

  • Install the client
  • Set up the client
  • Start the client

Sharing logs that provide context from when you started the client to when it failed would be helpful as well.

my issue was that /etc/twingate was not set up with correct ownership.

sudo chown -R root:root /etc/twingate solved my issue


The folder was indeed setup with the wrong user.

changing to root fixed the issue.

I have this issue too. I’m on Arch… My /etc/twingate folder owner is my user by default, I tried to change it but I didn’t think in root when did it. Ty @ironrobin !