Running linux client headless - Not authitenticating automatically on powerup

Hi all,

I’m trying to get twingate to automatically log in on boot headless but it won’t work without manually clicking on a link when running the sudo twingate status command.

When running the setup command I get this

Do you want the Twingate service to automatically login after restart? This requires saving authentication data in /var/lib/twingate (accessible only to root)

How or what do I put in the .json authentication file to make it automatically log in?

I am using a third party login to the account (Google/MS)

Hi Feithin,

To be truly hands off/headless, you will need to use a Service Account and then deploy using the Headless Linux Client instructions.

If done that way, the service will start in the background, and authenticate automatically using that service key rather than requiring user input to authenticate as you’re seeing now.

Let me know if you have any other questions!



Thanks Arthur,

I set up a service account and pointed it at the .json file that the service account but it doesn’t work. I wonder is it because I’m running xubuntu and not ubuntu?

I think I fixed this. I uninstalled the application by purging it, restarting the os and then reinstalling it. Rather than going through the setup, I just setup the headless feature and pointed it at the service .json file. Now all I need to figure out is how to enable startup automatically at boot.