Unable to join Appen network

Hello, im unable to join Appen network, the loading circle turns and then disappears and when i checked the logs it said :
[ERROR] [CLIENT] Failed to create the communication channel. No IPEndpoints were found for host 127.0.0.1.
Help would be appreciated
Thank you

1 Like

Hi @Meryem, were you able to resolve this by starting the service?

1 Like

No before after installing twingate there’s a popup saying that it requires a restart and i used to click yes and when the pc restarts it doesn’t let me join the network. Today i tried not restarting my pc after installing twingate and it worked.

1 Like

Are you able to provide a screenshot of the popup?

Possibly sounds like the service is not starting on a reboot. Does it persist each time you restart your computer?

1 Like

Unfortunately i can’t, the pop up only happens after finishing installing, its like a requirement for twingate for the configuration to apply or smtg like that and you can choose yes for the pc to restart now or no if you wanna do it manually later on.
But when i chose yes before and pc restart i can’t join the network and i get the error in the logs.

Ah got it! Well it sounds like its working now? Let me know if/when you reboot and the problem persists. Another thing we can check is the start type for the service, if for some reason it wasn’t set to automatic:

Powershell:

Get-Service -Name ‘Twingate.service’ | Select-Object -Property Name, StartType, Status

Should provide:

Name              StartType  Status
----              ---------  ------
Twingate.service  Automatic  Running

Hey, so i just restarted my pc and i was already connected to twingate, i think the problem is only when you choose yes on the pop up message and restart your pc before connecting to the network.

1 Like

Hello Grady,
I have been experiencing this issue and like you mention it the service doesn’t start automatically every time after I reboot my computer. So I have to start it manually after every reboot.