Issue connecting after installation on fresh linux system

I use the script to install. Went well.
Did sudo twingate setup. Went fine.

When I do twingate start, this is when things seem to go bad. The output looks fine:

~$ twingate start
Starting Twingate service
Twingate has been started; user authentication is required for access to Resources
Starting UI notifications
It looks like desktop notifications aren’t supported in your environment.
You can run /usr/bin/twingate-notifier console in order to receive
authentication requests from the Twingate service.

looks ok but:
~$ /usr/bin/twingate-notifier console
04:21:57 [ERROR] twingate_notifier::notifier::Notifier::start message process error: auth.sock socket is not found
04:22:02 [ERROR] twingate_notifier::notifier::Notifier::start message process error: auth.sock socket is not found

In the syslog, I got:
Jun 2 04:21:41 ip-172-31-50-23 twingate-cli[17454]: is_vpn_running err: No such file or directory (os error 2)

It seems like a directory was not created and it’s not handling it well. Since it does not output the directory it’s looking for, I don’t know what to create manually to get it working.

Linux Version:
admin@ip-172-31-50-23:~$ cat /etc/os-release
PRETTY_NAME=“Debian GNU/Linux 10 (buster)”
NAME=“Debian GNU/Linux”
VERSION=“10 (buster)”
SUPPORT_URL=“Debian -- User Support

Please Advise.

Hey there!

Sorry to hear you’re having these issues.

This error can crop up for a few reasons.

The two most common we’ve seen are that:

  1. twingate setup didn’t complete correctly. (You can try rerunning the command)
  2. There is some potential time drift between your machine and our servers (A difference of a few minutes can create authentication issues).

For #2 - we recommend ensuring your clock is synced via NTP as outlined here (How To Set Up Time Synchronization on Debian 10 | DigitalOcean)

If neither of those solve your issues, and if you’re comfortable doing so, can you please upload the zip generated by running twingate report so we can see the full log output and dig deeper if necessary.

Thanks for your understanding!

-arthur/Twingate Support

ReRan setup:

~$ sudo twingate setup
Twingate Setup | 0.120.0
By continuing, you agree to the User Terms of Service (User Terms of Service)
and acknowledge the Privacy Policy (Privacy Policy). [A]gree/[q]uit:
Your current Twingate network is ‘xxxx’. Do you want to change it? [y/N]: y
Enter the name of your Twingate network (eg. “acme” for “”): xxxx
xxxx is a valid Twingate network
Do you want to automatically start the Twingate service at boot? [Y/n]: y
Enabled Twingate to start automatically
Do you want the Twingate service to automatically login after restart?
This requires saving authentication data in /var/lib/twingate (accessible only to root) [y/N]: y
Do you want to automatically share application error reports with Twingate? [Y/n]: n
Do you want to start Twingate now? [Y/n]: y
Twingate has been started; user authentication is required for access to Resources
To start desktop notifications, run twingate desktop-start.
Alternatively, you can run /usr/bin/twingate-notifier console in order to receive Twingate authentication requests in the console.
~$ /usr/bin/twingate-notifier console
02:01:18 [ERROR] twingate_notifier::notifier::Notifier::start message process error: auth.sock socket is not found

Time is syncing:
~$ timedatectl
Local time: Thu 2022-06-02 22:03:14 EDT
Universal time: Fri 2022-06-03 02:03:14 UTC
RTC time: Fri 2022-06-03 02:03:15
Time zone: America/New_York (EDT, -0400)
System clock synchronized: yes

I dont see an upload option?

I was having a issue with twingate getting the same auth.sock error.

So story time.

I was running twingate no issues with 34/35/most of 36 Fedora. So one day just ran into the issue. I could not fix it for anything, uninstall/reinstalled/deleted files etc. So I just create a VM to run twingate in to continue to do my work. Then I decided I would upgrade to Fedora 37. Did that from the cli and it all went well, kinda. I notice upon reboot that it took about 5mins for my network to come up. Now being a upgrade I was thinking maybe a net driver issue. I’m using a HP Pavilion Desktop TP01-2xxx which is kinda of linux supported. Well I was looking around and thought I would run ‘nmcli connection show’ well let me tell you I was surprised. I saw hundreds (yes hundreds) of sdwan0 in connection name. I knew pretty much that was twingate as when I did ‘ip route’ the 100* ip would show up. Well I uninstalled twingate. I then remove hundreds of sdwan0 connections rebooted and bam! My network was fast to connect after I logged in. I then reinstalled twingate. Then I tested it. I did get the “We have detected that another VPN connection is active.” Which is odd as I did ip route and had all 192.168.*.* routes so not sure where it is getting that idea. But I said yes connect anyway. So far at this time the connection is working it is prompting for a long and I have pinged a system for 2 hours with no drops.

So my suggestion is do ‘twingate stop’, uninstall it, do ‘nmcli connection show’ if you see any connections of sdwan0-* remove them (all), then reboot. Reinstall twingate, try to log in.

Good luck,


1 Like