Can't setup: browser not found

  1. I’ve never seen an idea worse than setup via notifications.
  2. Browser is not detected, but it is definitely present in my system and it is detected by every other application. Perhaps twingate is not using XDG desktop protocol?
  3. How can I see the link to click and call browser myself?

Hi @noid,

could you share more information on what is not working? are you attempting to install the Twingate Client? if so, on which platform / OS?

Yes, sure

$ uname -a
Linux grid 6.1.51 #1-NixOS SMP PREEMPT_DYNAMIC Sat Sep  2 07:16:20 UTC 2023 x86_64 GNU/Linux
$ twingate --version
Twingate 2023.250.97595 | 0.149.1

I have set it up successfully with sudo twingate setup.

I am running

$ twingate start
Starting Twingate service
[sudo] password for user:
We have detected that another VPN connection is active. Please close that connection before connecting to Twingate. Do you want to try to connect anyway? [N/y]y
Twingate has been started; user authentication is required for access to Resources
Starting UI notifications
Enabled desktop notifications

I get two desktop notifications

  1. “Twingate Client Sign in to Connect click here to finish signing in and connect to your Twingate network”
  2. And when I click I get “No browser found”

XDG and mime types are set up correctly

$ xdg-settings check default-web-browser firefox.desktop
yes

How do you lookup the browser? I hope it is not just querying /usr/bin :pray:

hi @noid, based on the message returned, it is possible something else in running on your machine and causing the incompatibility. Do you happen to be running an Antivirus or another VPN solution on your Linux box?

There is a self-troubleshooting guide as well here that may be useful: https://help.twingate.com/hc/en-us/articles/9370365449757

I have to VPN running, I have some virtual interfaces defined, but they’re definitely not interfering with the twingate.

And again, please take a look at the report, program states that the “No browser found”.

We have seen incompatibility with some AntiVirus on Linux as well. The “no browser found” error message is consistent with an incompatibility. any AV running?

No AV set up too. We can get to the solution from the other side, how do you check the browser?

@noid, let me do a bit more research on how the Twingate Client identifies the browser to use.

hi @noid,

the Linux Client primarily looks for a BROWSER environment variable and if it doesn’t exist, it tries a few other system commands.

Can you confirm that running the following command does open Firefox in your case?

xdg-open https://google.com

Yes, xdg-open works correctly, I’ve provided details with xdg-settings check. I’ve tried running BROWSER=/path/to/firefox twingate start

I think I know the cause of the issue. Does twingate check it from daemon or from foreground process? Daemon is usually executed from user with privileges (root any something like this), and this user usually has no access to BROWSER env variable and this user has no xdg and mimeapps.list set up.

Hi @noid, you are correct, the underlying process of the Twingate Client runs as a daemon and with elevated privileges because it needs to operate its own Network Adapter so you might very well be onto something here…

Hi, did you manage to fix this behavior yet? Nobody uses browsers from daemon user in unix systems.

Bump, I can’t work until this gets fixed. My company is paying for this product.

  1. It is not correct to start browser from daemon user.
  2. Why would you even want to start the browser, just write the link into cli output and that’s it.
  3. Why would you even want to set up authentication through notifications? You already have cli request/reply flow, use it!

cc @Bren

I’ve passed your comments on to our client dev team. We’ll look into some alternatives to support your use case.

As a workaround, you should be able to run /usr/bin/twingate-notifier console after running twingate start and receive the link to copy and paste into a browser in order to authenticate manually.

Please let me know if that doesn’t work for you.

Thanks,

-arthur

1 Like

Yes, it works. I’ve also found another workaround with twingate status