Cannot download any of the Linux Clients

Hello, I am trying to test out twingate, but can’t seem to locate the *.deb linux package.

When I run the installer, all I get is:

Fetched 18.6 kB in 2s (9,630 B/s)
Reading package lists…
Building dependency tree…
Reading state information…
All packages are up to date.
Reading package lists…
Building dependency tree…
Reading state information…
E: Unable to locate package twingate

Can someone help me please?
when i open the script, and try to browse to
it results in a 404 error.

I am trying to install the client on debian on a Raspberry pi.

Any help appreciated.

Welcome to the community!

What commands are you running to try and install the Linux Client?

HI AlexB, thanks for responding.
I am following the instructions exactly as they are posted here:

so I start with:
curl -s | sudo bash

Is there something I needed to do to ensure these prerequisites?

System Prerequisites

  • The Linux Client requires either systemd-resolved service to be enabled/running or NetworkManager service to be configured and enabled/running as the client DNS service.

Thanks again.

Those prerequisites shouldn’t be a problem on Debian, but it could be something weird about Raspbian not quite working for the script.

Could you try the manual installation method and let me know if that works? You may need to preface each command with sudo, e.g.

echo "deb [trusted=yes] /" | sudo tee /etc/apt/sources.list.d/twingate.list
sudo apt update -yq
sudo apt install -yq twingate

@brinx338 can you verify that this Debian image is the X64 version? I believe that running hostnamectl will tell you if it is x86_64 or x64.

Thanks for checking. my platform is Arm, not x86… Raspbian lite I believe.

I ran the command as seen below:

:~ $ hostnamectl
Static hostname: viewport
Icon name: computer
Machine ID: 6xxxb756ccf549998546c1c799c0e160
Boot ID: 871d538fecab42bea3a5a38278a988dc
Operating System: Raspbian GNU/Linux 10 (buster)
Kernel: Linux 5.10.103-v7+
Architecture: arm

Hello again,
I also tried the manual installation method but the result is the same…
and ends with:

~ $ sudo apt install -yq twingate
Reading package lists…
Building dependency tree…
Reading state information…
E: Unable to locate package twingate

when looking at the manual installation URL, if I browse to:
should I get an error? or should I be able to see the source?

I don’t think that URL works, or the package has moved, or something.

Please let me know.


I see. Thank you for the follow up. I have a Raspberry Pi currently running ubuntu server 22.04 64bit. We only have binaries for 64-bit OS. I will test and see what I can accomplish. I will check back shortly.

ubuntu@ubuntu:~$ hostnamectl
Static hostname: ubuntu
Icon name: computer
Machine ID: 73f506ac1cf64f98a25742eb48c85e5b
Boot ID: e30d41b7ac3449a9a991c12e5d42acbc
Operating System: Ubuntu 22.04.2 LTS
Kernel: Linux 5.15.0-1026-raspi
Architecture: arm64

It looks like the issue is your architecture is arm but the OS is 32-bit.

If you open the apt repo URL in the browser we currently don’t display anything, hence why you get a 404 error and see Not Found. You can verify that packages are present in the repo by running apt list -a twingate on your machine. I’ll see if we can improve this.

However, like @chris-twingate said, we only support arm64 and not arm, so you won’t be able to download the client to your specific Raspberry Pi.