Error: auth.sock socket is not found

I’m on Manjaro Linux, this is my first time posting for help in twingate forum.
How do I resolve the “Error: auth.sock socket is not found” ?
Tried to execute two or three times the twingate setup command, which I’m thinking that maybe I miss some parameters.
Read the forum and found this Failed to start Twingate Arch Linux
Do the NTP things but still not solve my problem.
Can somebody help me to solve this error?

Can you confirm that you are indeed running/utilizing NetworkManager in your install?

As well - can you run the following list of commands:

sudo twingate config log-level debug
sudo twingate stop
sudo twingate start

And then attempt to connect again, and if it fails, please provide the logs either here or via email to me at arthur (at) twingate.com and I can take a look.

Thanks,

-arthur

Checking the networkmanager and not found anything unusual except the list of Wi-Fi AP and cable connection information
And trying the suggested command, somehow, when execute the sudo twingate stop, the twingate service was stop and sudo twingate start then it shows messages starting Twingate service and open the browser for authentication. After the authentication process through the browser is finish; the twingate is connected and the status is online.
I think, something between the stop and the start of twingate service makes my twingate works again.
Thank you for your help.

I had this problem on Manjaro Linux and found the problem (for me). The installation process created the /etc/twingate directory with my username as the owner rather than root. I did a “chown root:root twingate” and that solved the problem. I just had to restart twingate.