Unable to use Twingate to access protected Saas applications


I am facing an issue with Twingate. I have created a Twingate network and have deployed the connector. I have also download the client and can see the status of the connectors as “online”.

Now I have added a resource. It is a third party Saas application which allows login only from some static IPs. I have added the public static IP of the AWS instance where I have deployed the connector.

I would want twingate to use the IP address of this AWS instance whenever I visit this SaaS application and when twingate client is connected in my local machine. But this isn’t working as expected.

I have tried nslookup and can see that twingate is intercepting the traffic. I can also see the logs in twin gate portal but the ip address is not changing from the clients ip address to the AWS instance ip.

Any idea in resolving this issue will be very helpful?

Hi finiteL00p,

Something that tends to happen when trying to tunnel data to a third party website is that you create the Resource very explicitly, as in “google.com”, and you end up not capturing traffic that would be going to www.google.com or help.google.com and so on.

A lot of websites use subdomains for their APIs or other services that you don’t see unless you start inspecting traffic, so you’ll want to make sure you account for that when setting up your Resource.

Try using wildcards in the Resource definition (check Resources | Docs for more details), like “*google.com” would capture all traffic destined for anything that ends with “google.com”, which broadens the scope of the Resource a bit and hopefully captures the missing hidden traffic.

Also open the developer screen of the browser and watch the network tab as you load that third party website, check to see what other domains it may be trying to access other than the one you’ve already created a Resource for. This way you can see if there’s something that’s been missed and you can create a Resource to capture that traffic as well.

I have tried your suggestion and it has worked. Really appreciate your help.