Twingate should be working

Hello all. interesting issue that I am trying to understand.

Setup ;
Twingate server running on Raspberry Pi 4b
-Client running on Windows.

Issue ;
-unable to reach resources through Twingate

Verified ;

  • server shows connected
    -resources show connected
    -client shows connected
    -I am the only user in one group (everyone)
    -I am able to reach resources locally
    -services are running on windows
    -able to reach internet while Twingate is running
    -added resources by IP to make sure dns was not issue

Things I have tried ;

-reinstalled controller
-reinstalled client
-checked logs (nothing stood out)
-readded user/groups/resources
-scanned ports on server (did not seem to show open)
-manually added dns servers to pi

I do notice client does not show a default gw. I have looked through articles but am unsure if this is normal behavior or not.

Thank you for your time on this.

Hi Myk,

If you SSH into the RPi, are you able to ping/reach the local resources you’re trying to reach through Twingate?

It sounds like everything is set up as it should be, but the main issue will be connectivity between the RPi and the rest of the devices. I do see that it looks like the RPi is on a different subnet from a lot of your resource definitions…


Thank you for your reply. Great question. I AM able to hit all resources with the RPi. I may have failed to mention the reason for the different subnets. They route over an L2TP connection back to an office. I have tested with both ip addresses and internal domain names and they are able to reach each other. I have some funny routing with 10.x.x.x and 100.x.x.x for c-grade nat in my router over the l2tp. If you feel like the setup on my Twingate is good I will check some of my routing and see if that is the cause. If I discover the reason I will report back.

reporting back an unfortunate update. I have removed all routing for 100.x.x.x No luck. I also noticed that my twingate adapter does not have a default gateway. Is this normal behaver? When running a trace it errors out immediately. I did find something interesting. system-info reports my ip address is with no default GW, but had a route set to .209 I thought I would statically assign this, but it kept throwing an error back saying my ip/subnet was wrong. It also reports my DHCP server as - I tried .209/30 with .210 being my GW just to test. It took it, but was unable to reach resources. IP Calculator / IP Subnetting

Hi all. Reporting back some good news. Its working now. I disabled all resources and created a new connector on site (keeping that as it seems cleaner) and as I was re-enabling resources it broke again. It appears one of my resources was an IPv6 address. For some reason there was a conflict. I’m not up on IPv6 as much as I should be so I do not have specifics, but if you have any, try disabling that resource and testing the other ones. Hope this helps someone in the future.