Jetson Nano Connector 4.9.299-tegra

Hi All,

I tried to install a connector into my Jetson Nano running

VERSION="18.04.6 LTS (Bionic Beaver)"
PRETTY_NAME="Ubuntu 18.04.6 LTS"

The service reports

● twingate-connector.service - Twingate Connector service
   Loaded: loaded (/usr/lib/systemd/system/twingate-connector.service; enabled; vendor preset: disabled)
   Active: activating (auto-restart) (Result: exit-code) since Tue 2023-06-06 17:23:23 CEST; 212ms ago
  Process: 4857 ExecStart=/usr/bin/twingate-connector --systemd-watchdog (code=exited, status=1/FAILURE)
 Main PID: 4857 (code=exited, status=1/FAILURE)

The /etc/twingate/connector.conf looks ok

Any ideas ? is it compatible with Nvidia Tegra?

Hi @Jamest65, thanks for posting. Ubuntu 18.04 has reached end of life - Ubuntu 18.04 End of Life | Docs

Do you run into this issue with the supported LTS versions 20.04 or 22.04?



Hi Aaron,

I have a hyper v ubuntu 20.04 and noticed that the install wasn’t creating the connector.conf, I am going to have a look at the tegra and create the connector manually to see if that resolves that also.

@aaron update I tried to create the connector.conf on the Tegra Jetson Nano and it still wont load the service.

found this in journalctl -xe after manually creating the connector.conf

Jun 06 19:22:15 desktop twingate-connector[13856]: /usr/bin/twingate-connector: /lib/aarch64-linux-gnu/ version `GLIBC_2.28' not found (required by /usr/bin/twingate-connector)

hope it helps

Upgrading to Ubuntu 20.04 should solve this problem as it came with GLIBC-2.31.

1 Like

Thanks alexb i have started the upgrade and will report back

Jetson NANO with upgrade to ubuntu 20 can be a issue with many cuda or gpu drivers

A post was split to a new topic: Issues setting on Twingate Connector

Thanks been through that a few times I just install multiple versions of gcc

I followed this just make sure you uninstall chromium-browser as it messes up the upgrade dependencies.

Upgrade Tegra to 20.04

How did the upgrade go? Are things working now?

I rebuilt it and will run the upgrade again and should be fine

1 Like