Asustor AS6702T connectors wont run

New to Docker and Portainer.

I have not been able to get any connectors to run. Ive tried various methods of setup:

  1. SSH with provided Docker Run command
  2. Manual container creation with Portainer based on Synology setup instructions
  3. Manual container creation with Portainer based on Docker Run command, with my questimation of what went where.

All have the same result: container starts, says “Healthy” for 30seconds to 1 min then status changes to “unhealthy”.

All container logs show the same error:
[ERROR] [libsdwan] healthy: controller is not healthy
[ERROR] [libsdwan] healthy: controller is not healthy
[ERROR] [libsdwan] healthy: controller is not healthy

Im not sure what this means or where to look. I feel like this is a networking issue and that the container ist able to get to the internet but not sure how to troubleshoot that since no other NAS apps or VMs have issues getting to the internet.

Anyone able to help me get started figuring this out?

1 Like

Hi @system2600, I think the issue might be related to the Docker container not being able to reach the Internet. Can you provide details of your OS and whether it is possible to test with our Linux systemd Connector instead - at least to validate that works?

On a more technical level, you can increase the log level of the Twingate connector in Docker using the instructions here: - however, before going down that route I would definitely check if your docker containers can resolve DNS correctly and access the Internet generally.

Thank you. I’m in the process of setting up a second device and once I get to the Docker install, I’ll be trying again with Twingate on a fresh build so to speak. I will definitely look into this if I notice the same issues occurring on the first machine.

1 Like


I dunno what I did or didn’t do the first time but on a clean Docker/Portainer install, I had no issues.

Thanks for checking on me anyway :+1:

1 Like

Hey @system2600, great news that you got things working! Please reach out if we can help again and have a great weekend.


I’m late to the party here but wanted to jump in as I run a AS6604T personally and am curious how you were deploying Twingate in Portainer.

The yaml example found in the below link (its a new newer docs page) is what I’ve been running for the last ~1.5yrs.

If this does happen again in the future, the logging without debug level logs here unfortunately isn’t going to give us details. It could very likely be clock drift as it’s sensitive to a 5s drift from the Controller.

Also keep us posted if this does recur as I’d like to see what the culprit is on your NAS/configuration.

As a side question, did you ever try to perform the docker run command outside of Portainer? When I tried doing that ~1.5yrs ago there was a character limit with the CLI. I had to separate the tokens into their own variables, and then use those variables in the docker run command. Curiosity if you/others may have hit that.

I had tried a few different methods at the point of posting I was decomposing the command Twingate provided and putting it in the appropriate Portainer sections when creating a new container. Im really not sure anymore what all I was doing/trying but I partly was using the Twingate/Synology setup instructions as a guide as Synology has it’s own Portainer-ish Docker flavor.

How to Set Up Twingate on a Synology NAS | Docs | Twingate

After posting I even tried SSH-ing to my NAS and just running the Twingate command and seeing how that looked in Portainer and even that didnt run at first.

Then for some reason one of the attempts I left in there it just started working. :man_shrugging:

Honestly I think there were a few factors at play.

Initially I think I messed something up learning. Then tried so many times under a condition I suspect never would have worked, I eventually just wiped everything out and reinstalled Docker and Portainer from scratch. At that point when it wasnt working I think there was something going on at Twingate and/or with my connectors. It was after I stopped trying to use the originally offered connectors and started messing with new ones (which also initially didnt seem to be working) that I left everything overnight. The next day when I started retrying them I noticed one had actually connected to Twingate but I had already deleted it in Portainer thinking it failed. I reentered the info via Portainer and waited a bit longer and it was connecting so I just left it.