Connector container not connect

I’m running the connector in my QNAP NAS but I have tried several things without success. I followed the instructions on the support site to install the connector on QNAP NAS.

…but that is the happy path, I couldn’t find any other document that helps to solve possible issues. In my particular case logs give me:

State: Offline
State: Authentication
[msg] Nameserver has failed: request timed out.
[msg] All nameservers have failed
[msg] Nameserver is back up
[ERROR] [libsdwan] healthy: controller is not healthy
[ERROR] [libsdwan] healthy: controller is not healthy
[ERROR] [libsdwan] healthy: controller is not healthy
[ERROR] [libsdwan] healthy: controller is not healthy

[ERROR] [libsdwan] healthy: controller is not healthy

I have other containers running in my NAS and they are able to access the Internet without any special configuration but this one seems not able to connect.

Hi @rsotolongo, from the error it seems like there is a problem with DNS resolution within Docker on QNAP.

I’m not super familiar with QNAP but did a bit of research and can suggest trying some things:

  • Try adding --dns --dns to your docker run command for Twingate - this will add Cloudflare’s DNS as a secondary DNS resolver.
  • This one is a bit old but there’s a report that if IPv6 is enabled then DNS is broken - you may want to see if this is the issue affecting you: Reddit - Dive into anything

I can also suggest asking on the QNAP forums as to why DNS may be failing in your Docker container. Apologies for not being able to offer an immediate concrete solution to this but hoping these suggestions will help.

Thank you for your recommendations.

Adding the --dns options (any or any combination) the logs don’t show any message about Nameserver, always get:

State: Offline
State: Authentication
[ERROR] [libsdwan] healthy: controller is not healthy
[ERROR] [libsdwan] healthy: controller is not healthy
[ERROR] [libsdwan] healthy: controller is not healthy

IPv6 has been OFF all the time.

How can I execute commands in the running connector container? I tried several commands but without success:

sudo docker run -it twingate/connector bash

sudo docker run -it twingate/connector echo TEST

sudo docker run -it twingate/connector ifconfig

I will use QNAP forums as well looking for new clues.

Hi @rsotolongo - our connector images are stripped down for security reasons so only contain the connector binary. To get an interactive bash prompt to test whether DNS is working you should be able to use an Ubuntu image or similar, e.g.: docker run -it ubuntu bash.

Can you try that and let us know if you can then resolve DNS normally (using nslookup or dig)?


After execute the following commands:

docker run -d ubuntu

docker run -it ubuntu bash

apt-get update

apt-get install netutils

apt-get install dnsutils

apt-get install net-tools

apt-get install iputils-ping

apt-get install traceroute

I execute these other four commands…

…I don’t see any problem from that container, but the connector container is still unable to connect. Do you see something that can help from the results of those commands?

Hi @rsotolongo, from this log it seems that DNS and internet connectivity is fine. I wonder if you can re-run the Twingate connector with an additional flag to enable more comprehensive logging: --env LOG_LEVEL=7. More information logging is available here.

Could you share the output when the connector starts up?

Thank you for the command, I’m getting more information now. It seem a problem with the token but doesn’t make sense I have generated new tokens several times but logs are the same. I also created a brand new connector with new tokens, etc. and same result. I can’t share the plain text logs because forum system limits me to only two links (URLs) but I’m sharing in screenshot format. I’m sorry, I need help…

Hi @rsotolongo, thank you for sharing. That error suggests that the problem is related to the system-clock being out of sync. For more info you can refer to here but the solution should be to ensure the clock is correct (ideally by enabling NTP).

I did another little search and am wondering whether you can try this document: How to synchronize NAS system time with a public NTP server? on the QNAP site.

@Emrul THANK YOU! That was the “magic”:

State: Offline
State: Authentication
State: Online

1 Like

Wonderful, it is great that you’re now up and running @rsotolongo! Thank you for your patience and for making it easy for us to trace the issue with you.

Take care!


1 Like