Alias limitations? Some aliases work, some don't..?

I am surprised and impressed I can set aliases for my remote computer to “” or my personal website “” even though I have no such DNS settings on it!

However, I want to ssh in like this “ssh” … but this does not work. I know the .ie TLD is valid, but why is “v” not working but “xav” does? I also tried “” and that also worked.

Does anyone know if there is a reason why I can’t alias to “”?

Perhaps all domains must be at least two characters? I really wish “” would work as alias!

Hi there.

Can you tell me what platform you’re running the Twingate client on? I just did a few quick tests and had no problem using as an alias and SSH’ing in to the particular host from either a Windows or MacOS machine.


Hey @Arthur, on the alias, I am trying to setup one for my NAS and using the IP address of it and for example When I go into a browser and type the alias its not coming up. When I ping in a terminal, it comes up with a completely different address.

Any ideas? Thanks

Hi @bdhela,

the fact that a ping returns a different IP address (that I assume is an IP address in the CGNAT range) is actually expected and a sign that the Twingate Client is indeed intercepting traffic for that alias. (You will find the full explanation as to why a CGNAT IP gets returned in the documentation here: How Twingate forwards DNS | Docs).

Could you share a screenshot of what the browser looks like when connecting to your NAS’s UI from it? what port is the UI of your NAS running on?

Here are the pics:

Hi @bdhela,

this error is a browser error, not a Twingate one: your browser is refusing to connect because there is no certificate attached to your .com domain for your NAS. Typically, browsers allow you to ignore this error but it doesnt appear to be the case in the screenshot you shared. I would try with an alias that is not a .com alias but perhaps something with a .int. There is a chance your browser is actively blocking an override because .com is a public top level domain.

Thanks @Bren the .int worked but I still get the warning its an unsafe site.

The “unsafe site” warning is caused by the same thing that Bren was talking about. You don’t have a certificate on your NAS and most browsers, like Chrome, now warn users whenever a site doesn’t use HTTPS.

Thanks @alexb. Strange thing is I do have Certs on the nas. I’ll keep playing around with it.

What’s the certificate’s domain? The alias needs to match the certificate’s domain. (You might already know that, I just want to reiterate that could be causing the error.)