Address mismatch on received DNS packet.......Moved / new docker container now can't connect

I have a linux server running Bind9, MQTT server and now a Twingate connector. All in docker containers on the same docker network

I previously had a Twingate connector successfully running on a different linux server. I reused the docker compose set up to make a new connector. I set up a new connector entry on, deleted the old entry and copied the new access / refresh token across.

I cannot get the new connector online. The docker log says:
State: Error
State: Offline
State: Authentication
[warn] Address mismatch on received DNS packet. Apparent source was

I would be grateful if someone could help me


My Docker compose file:
image: “twingate/connector:latest”
container_name: twingate-xxx-xxx (name on
- .env
- Homecomms_internal
restart: unless-stopped

My .env file


TWINGATE_NETWORK=“xxxx” (name on




(I have also tried no DNS entry and ‘bind9’ the docker container name

Extracts from my log

[DEBUG] [libsdwan] forced expiration of the access tokens
[DEBUG] [libsdwan] operator(): twingate_label_hostname=hostname
[DEBUG] [libsdwan] [quic] init: new instance
[DEBUG] [libsdwan] [quic] on_accept: enabling server
[DEBUG] [libsdwan] reconfigure_direct_connect_socket: set the size of UDP socket buffers to 4194304 bytes
[DEBUG] [libsdwan] reconfigure_direct_connect_socket: reconfigured direct connect socket
[INFO] [libsdwan] sdwan_new: libsdwan_version=0.155.0, app_version=1.63.0, platform=Linux-x86_64
[DEBUG] [connector] connector start
[INFO] [connector] started server on /var/run/twingate/connector.sock
[INFO] [libsdwan] sdwan_state: Offline None
[INFO] [connector] State: Offline
[DEBUG] [libsdwan] [controller] run_state_machine: Offline
[DEBUG] [libsdwan] [controller] set_state: switching from “Offline” to “Getting public keys”
[INFO] [libsdwan] sdwan_state: Authenticating None
[INFO] [connector] State: Authentication
[DEBUG] [libsdwan] [controller] get_controller_keys: fetching controller public keys…
State: Offline
State: Authentication
[DEBUG] [libsdwan] submit_request: sending HTTP request 10919358496311395674
[DEBUG] [libsdwan] http::request::send_request: GET “” text/plain
[warn] Address mismatch on received DNS packet. Apparent source was

I solved this by

Making the TWINGATE_DNS=“” an external DNS server rather than my internal bind9 server