Windows App Will Not Launch Browser for Authentication

Hello all,
I have a Dell notebook, with Windows 10 installed (fully updated). The notebook has Avast antivirus installed.

The problem is the Twingate app, after entering network, and clicking the join network button will not launch browser for Authentication.

  1. App was installed as Admin (I’ve also tried launching the app as Admin) after first standard install produced same behavior.
  2. All Avast Features turned off
  3. Confirmed Chrome is selected as default browser.

No errors are produced, simply runs circle ‘thingy’ for a while but never opens a browser page.

What can I look for to debug this?

Hi @RJ_Make, this can happen if the Twingate client isn’t able to establish a secure connection. You can look into the Twingate client logs to determine why the connection failed. Two common reasons:

  • DNS failure
  • SSL inspection (some anti-virus software will MITM HTTPS connections, although I know you mentioned Avast features are turned off)
1 Like

So it turns out, after preventing Avast from ever starting on a reboot (didn’t want to uninstall for testing) allowed authentication through a browser launch.

I’m learning Avast is quite ‘invasive’, even when everything is turned off it’s still effecting the system in what seems like profound ways.

The error was something about communication with Winserver failed.

Thanks for your help!

1 Like

Amazing, thanks for the update @RJ_Make. Most AVs are quite invasive (I suppose they have to be since malware can be quite invasive also).

We suggest to use an AV that allows you to exclude certain programs/processes from inspection. Then you can exclude the Twingate client and service from inspection.

Ok so we had the Twingate client in the exclusions (first thing we tried), but didn’t know about a service. So perhaps the service was still being blocked.