What would cause the 'No Internet Connection' Icon? on Windows 10

What would cause the ‘No Internet Connection’ Icon? on Windows 10, while connected. Wan connection is working fine.

  1. Machine IP for resources (2)
  2. Alias are being used.



Have you checked this article to see if this resolves your issue ?

Windows leverages Network Connectivity Status Indicator (NCSI) to examine network connectivity by attempting to connect to a handful of Microsoft-hosted IPv6/AAAA and IPv6/A endpoints. If native IPv6 is present, Windows will default to preferring IPv6 over IPv4, and if resolving the designated Microsoft AAAA DNS endpoints fails, NCSI indicates no Internet access (even if resolving the A DNS record succeeds).

I’m sorry, yes I did run that command with the same results shortly after a reboot.

I’ve also found an app that cannot reach the internet while in this state. (Acronis) I suspect it’s not even trying to connect and just seeing the windows “no internet state” and fails to perform backup.

More observations on this problem. It appears this condition is only present when the machine wakes from sleep.

This is becoming a serious problem with clients that are allowed to sleep. With the latest windows client version it blocks all communication on wake now, until Twingate is disconnected.

I’ve been loving twingate so much but this as become a big issue that I’ve had to revert to our old way of doing things. This is a big issue indeedthat should be addressed. I’ve had non stop tickets about this. So I hope they fix this I have also tried the ariticle that Steven has asked about at no success.

1 Like

Hi there, I’m experiencing something similar, but I can’t seem to get that link to open regardless of how I log in, makes me sign in and then lands on the generic help page each time… is there another way to access the info?

For reference… I’ll be happily connected to my network at home and all of a sudden I get the ‘no internet connection’ icon, work VPN dies and DNS goes a bit mad. It had worked well for a while and feels like recent connector/client updates have coincided with it starting to misbehave. Anyway, keen to read the above is possible. Thanks.

Hi skinnyl,

Apologies, as it looks like the permissions on that article had gotten tweaked. It should now be viewable for you!

As well, I’ve added a second potential solution to the problem which is a registry edit that makes a minor change to how the connectivity checks process DNS.