Very slow RDP Authentication (2+ Min) (Solved)

Hello All,
New to TwinGate and Zero Trust in general.

  1. Client on ~500Mbs WAN Server on 1Gbs WAN. Both Machines Windows
  2. Resource is limited to port 3389, everything else is blocked
  3. When using hardware VPN (UDM); RDP Authentication and startup is <20 secs
  4. When using Twingate (without VPN); RDP Authentication and startup is >2min.

Using the machine IP vs DNS makes no difference in delay. The interesting thing is on the initial click on the connect button, the RDP window freezes for almost a minute, before showing the connection dialog.

I’ve tried with other clients and in different directions, RDP Authentication is all around painfully slow. I expected some extra delay from perhaps some additional overhead, but not like this.

Any help would be appreciated.

Hi @RJ_Make, thank you for trying out Twingate! Can you check whether you enabled UDP as well as TCP protocols for port 3389?


I did not enable UDP 3389, So I’ll enable that and report back.

1 Like

That was the problem.

Thank You!

1 Like

Fantastic, thank you for reporting back. Microsoft added UDP support to RDP to improve performance. I suspect because it was blocked it was causing a timeout as your RDP client was probably trying to connect over UDP first and falling back to TCP.

Best of luck on your Zero Trust journey!