Unable to install docker connector on CentOS7

Tried installing the connector on CentOS 7 using the command

“sudo docker run -d --sysctl net.ipv4.ping_group_range=“0 2147483647” --env TWINGATE_NETWORK=“citadel01” --env TWINGATE_ACCESS_TOKEN=“XXX” --env TWINGATE_REFRESH_TOKEN=“XXXX” --env TWINGATE_LABEL_HOSTNAME=“hostname” --name “twingate-mustard-ferret” --restart=unless-stopped $(docker run --help | grep – --pull >/dev/null && echo “–pull=always”) twingate/connector:1”

But keep on receiving the error:

“docker: Error response from daemon: Head “https://registry-1.docker.io/v2/twingate/connector/manifests/1”: read tcp> read: connection reset by peer.”

tried running commands like:

systemctl unmask docker
systemctl unmask docker.socket
systemctl restart network
systemctl restart docker

and even reinstalling docker but still get abovementioned error. Please so advise, thank you so much in advance

Hi CiTaDel,

This looks like there could be an issue with your network connection. Do you have any sort of proxy or filtering/forwarding set up on your network? The EOF error denotes some likely issue between yourself and docker.io rather than anything specific to Twingate.

If you try running docker pull busybox does that work as expected?



Hi Arthur,

I’ve managed to solve it. Apparently, I uninstalled Docker completely, did a docker logout and it works but for sometime.

I manage to install the agents for sometime now but as I tried to reinstall the connector. I face the error attached below. Please advise what should I do to be able to pull the image via docker.

 "docker: Error response from daemon: Get "https://registry-1.docker.io/v2/": tls: failed to verify certificate: x509: certificate is valid for mobilesearchservices.com, *.mobilesearchservices.com, not registry-1.docker.io.
See 'docker run --help'.

Thanks so much and I look forward to hearing from you soon