Twingate on OSX not connecting (Ventura)

So i’ve tried it on two different networks now and basically, the phone’s client connects just fine. but my desktop app won’t connect.

It seems to install the VPN configuration fine (no errors) but it never really connects (just the alternating icons, then stops)

I tried deleting the app and reinstalling, removing the VPN config and re-installing (when i launch the app) and same issue.

What else could I check or do to get the desktop client to work?

The connector is run via docker in my NAS - but I don’t think there’s any issue with that because like I said, the phone can connect fine.

Hello Nergalzuis,

Sounds like your connector is fine. The issue is likely with the MacOS client.

If the twingate icon is just flashing and not prompting for authentication you will need to look at the client logs to determine the issue. The first step of the client is to reach out to the controller and grab the public keys. This requires a DNS resolution and SSL verification.

3rd party applications such as Adguard or maybe other VPN clients that are installed can cause issues with the above even though they are not running.

Again, the logs should give you some clue as to why the client isn’t connecting to the tenant network and you can go from there.

Hi Steven,

You’re right - I do have AdGuard installed and Twingate connected as soon as I turned it off.

A few questions though:

  1. I also have AdGuard installed in iOS but that didn’t affect the Twingate app - why is this?

  2. I’m considering implementing AdGuard Home to solve this (and point the router’s DNS to it) so i wouldn’t need the [conflicting] desktop client installed. However I believe this will protect me only when in my home network connected to my router.

What kind of approach would you recommend that would allow me to use adguard AND twingate regardless of where I am?