Twingate Connector will not connect to the internet

I used this Guide to install Twingate on a Windows 10 computer with Multipass and Chocolately:

Deploy Connector on Windows with Chocolatey | Docs | Twingate

It has been running fairly well for a while on the device and then all of a sudden this week it was losing connection, reconnecting, and booting us out of our RDP sessions. So I tried rebooting everything, then updates, and finally scrapped it all, uninstalled the controller, and installed a new one. After a lot of troubleshooting new connectors not getting IP addresses after using the command “multipass list”, I was finally able to get an IP. I am now stuck with the connector not connecting to the Twingate instance or the internet. It shows offline in the console, or never connected technically. So as a final try, I ran updates on the connector and got these errors (Shown below) with the command which makes me believe there are issues connecting to Twingate Services. The Windows 10 does have access to the internet because I am remotely connected to it another way with no issues.

C:\Windows\system32>multipass exec flying-starling – sudo – sh -c “apt update && apt install -yq twingate-connector && systemctl restart twingate-connector”

(, connection timed out Could not connect to (, connection timed out
W: Some index files failed to download. They have been ignored, or old ones used instead.
Reading package lists…
Building dependency tree…
Reading state information…
E: Unable to locate package twingate-connector

(I could not put in the full message because the error messages as links and I am only allowed to post 2 links per post.)

Is there any sort of EDR or DNS Filtering software running on either the Windows machine itself, or something at the edge firewall for that network? The failure to connect to the repository suggests something is maybe getting in the way, either at the network level or at the certificate level. The IP you’re getting back is still correct, though.

If you try visiting in a browser from that Windows machine, does it load?

I can get to that webpage from the Windows 10 computer. I do not have any EDR or DNS Filtering enabled on that computer. I also noticed on the Network and Sharing Center page in the control panel that before these issues started when it was working I know it was showing up as a public network and said no internet. But now I don’t see it in there under the normal network adapter.