Raspberry pi install


I having problems with my installation

Environment is Raspberry Pi, Open Media Vault ver 6, docker. Portainer, Plex and Jellyfin

When I install my container in docker the status is Healthy. But my Twingate environment is not connected. I think port 443 is the issue as OMV uses this port. Is there a solution I can try

You are running the connector in docker? Would you be willing to try to run it natively? It runs great that way and is has minimal load. (this is how I run it)

Just to be clear I just use the linux install and off and running.

Hi @Melbourne,

what do you mean when you say that your Twingate environment is not connected? That you don’t have access to any of the Twingate Resources you declared? if so, are you using Resources declared as IP / CIDR Blocks of Fully Qualified Domain Names?

I am using CIDR option. When I install it for the first time it connects. When I care at a resource eg Plex I use the zip address of my raspberry pi where I installed Twingate . I cannot enter a port eg 32400 (no option)
When I sign into the web services thee connection to my raspberry pi is has a not connected status

hi Melbourne. Here is how I access plex from outside my home while traveling.

  1. I have a Raspberry Pi at home that is running the connector. The Pi also happens to have Plex installed, but Plex could be anywhere the connector running on this Pi can access. I am running the connector on the Raspberry Pi using the Linux install method.

2.I have entered several resources. One is named “Plex” and has the IP address and port of my Plex Server ( port 32400). I chose to restrict the ports, so I actually have 22 open as well. TCP only. I ensured to give my user access to the resource when prompted (everyone in my case).

  1. When I am at the hotel or starbucks I connect my laptop using the Twingate client.

I can then use PLEX normally using the IP address of my PLEX server (!

It works awesome and is only limited by the bandwidth of the hotel or coffee shop etc.

Hi thanks for that.
But my connector is PiHomeServer still cannot connect. I will try an experiment and create another connector on a different Radpberry pi not running OMV and see what happens

How did this go? Anything you learned or can share? I am interested to hear the problem/solution!

Same issue I received an email stating

Connector offline
The following Connector has been offline for more than 360 seconds.
I am going to try another experiment with different names and check my router settings

I am making progress . I successfully got Twingate to run on my raspberry pi. The issue was the connector name which I previously change now I used the default name. I can access twingate on my home wifi. When I try to access twingate on another wifi eg Starbucks it does not connect

Any ideas

When you say it doesn’t connect do you mean:

  1. The client on your laptop doesn’t connect?
  2. You cannot access a resource on your home network when you are connected to Twingate and at Starbucks?

I assume #2 and that is likely because of DNS.

What resource are you trying to access? Can you tell me the name and how you are accessing it?

Here are a few things to check, but usually this is a DNS issue:

When I try to connect to twin gate remotely I get the wheel of death. I do not get the screen to ask for my credentials e.g. google account

When I am connected to my home wifi I receive the screen to enter my credential

Any ideas?

Hi all

I have accessed remotely via Twingate. It works well on WiFI. The issue was when I use 4G I was not able to sign in using my google account eg no screen was provided. Is this a limitation of Twingate or is my 4G provider does not allow that type of service?

No this should work fine. I regularly use Twingate while tethered to my phone.

Do this for me. Let’s grab some client logs and then try the 4G option again. Then send me the logs.

In the Twingate client click More->Troubleshoot-> collect detailed logs.
Recreate the issue with the spinning wheel and then send me those logs.
You can find them by clicking More->troubleshoot->View Logs

Let’s see what is going on. This should work just fine over 4G etc unless your provider is blocking which shouldn’t be the case.

I have sent the logs to your support email

Hi Jason
Thanks for reacher out. It is a pity that Twingate support team does note have the ethics you have.

I tested using the following my iPhone on 4G and hotspot on. I used my wife’s phone using my iPhone hotspot and it works
I am going to the reverse soon

Hi Jason
There are the logs


(Attachment 2023-03-12-com.twingate.ios.tunnelprovider.txt is missing)

(Attachment 2023-03-12-com.twingate.ios.txt is missing)

Twingate works on an iphone14plus using 5G
So far it does not work on an iPhone 7 Plus using 4G on similar phones with the same SIM card.
I need to find a iPhone 7 Plus with a different SIM card

Sorry for the delay. I was OOTO for the week.

This is strange that one machine would allow it and not the other…
That should not be the case at all.

is there anything else that might be contributing?