Passkey/Biometrics user login with 2FA

Using Oppo Find X5 Pro with Android 13 and latest client apk version.

I activated Passkey in Android and selected 2FA with Code and device biometrics to login to the service account, which worked out perfectly.

But when I login inside the Android Client, this doesn’t seem to work. When I login, the 2FA site appears, but the Android overlay for using my Fingerprint does not, so I have to use the 2FA code from Authy. When this is successful the app asks to activate biometrics again and again on every new login, even if already set up user biometrics are visible inside the service account and in Android OS Passkey settings…It’s like a Biometric circle of doom. Tried with Chrome and Firefox Mobile. Both with the same result.

Could Webview be the culprit? When login to the service account I do it in the regular Android browser of choice, but the webpage component to login as client seems to be running over Webview.

Any suggestions?

Keep up the good work! I love your service!

Support for 2FA in the iOS and Android app will be released in the next client versions we release!

1 Like