MFA no longer works or allows me to reset

Hi, I have tried to set up MFA for the Admin Console using a Mac and the Keychain as the authentication app. Also, I have been using Github to sign in (which already had MFA enabled).

Initially, Twingate asked me to set up MFA at login, which was initially successful, but it set the MAF up on the github entry. I had to disable the MFA on github to allow me to login in and tried to re-enable MFA on Twingate.

The trouble started here as I was not able to set up MFA again, and any I set up with Github directly does not provide a correct code.

Is there any way to completely reset the MFA function?

It is not at all clear in the documentation (at least as far as I can see) on how to set this up correctly when the only method of signing is via an existing service such as GitHub or Microsoft.

If I have missed the instructions, please point me in the right direction,

Thanks, Richard

Hi @RDHoworth,

You should be able to delete MFA from your User’s page in the Admin Console, check the bottom right corner and look for TOTP, you should be able to reset it there.