Issue with computer joining local area domain with client installed?

I am wondering if anyone else has faced this issue? It appears my computer was not able to have a good DHCP convo with my local server while the client was installed. I tried disabling the Twingate adapter in ncpa.cpl but it did not change anything.

I tried unplugging the ethernet cable and plugging it back in, I tried giving my computer a static IP then unplug/plug in, etc… to no avail. I had the Twingate Client 2023.227.7863 installed on my computer.

My computer would not join the local domain and would not get access to the internet or be able to communicate with other devices on the network. I was able to ping the computer with the client installed from my DC/DNS/DHCP server, but I could not ping the server from my desktop.

The moment I uninstalled the client I had internet access and was joined to the local domain. I did not have to unplug/plug in the cable or mess with the adapter settings at all, it joined on it’s own.

Has anyone seen this issue before? Do I just need to make sure not to have the client installed if I am trying to join a computer to that domain? The machine running Twingate is Windows 10, and the server is Window Server 2022. I have searched but did not come across anything through the forums or through google, so I am thinking it is a misconfiguration of something on my end but would love to be able to say that definitively. If anyone could help me troubleshoot this, I would greatly appreciate it!

I just took a couple wirehark packet captures with twingate installed and also while I was uninstalling it. As soon as the uninstall completed, my computer joined the domain. I cannot dissect this well enough to see why. No one else is having this issue?