Installation on ubuntu >= 22.04

By trying to install the twingate cli tool on your ubuntu 22.04 you might encountered this issue:

Ubuntu 22.04 has upgraded libssl to 3, and does not propose libssl1.1…
So you can solve the situation by :

  • downloading the right libssl1.1.deb package
  • installing it
sudo dpkg -i libssl1.1_1.1.0g-2ubuntu4_amd64.deb
# remove the .deb eventually
rm libssl1.1_1.1.0g-2ubuntu4_amd64.deb

Then you can run again

apt install -yq twingate

Thanks so much for posting that!

We actually also have an article on this in our Knowledge Base as well, and we’re regularly adding new content to it, so if there’s ever any issues, please have a look there!

oh sorry for the duplicate :grimacing:
but isn’t it smoother to install a single package rather than adding a repo not compatible with our linux version ?

No need to apologize for the duplication, we appreciate the contribution!

As far as methods, its different paths to the same result - I think our motivation behind the repo addition is to keep it “simple” as far as using apt to do the install rather than dpkg, but now your post is here to provide an alternative!

1 Like