Failed to connect to resource

Hi there, I started using twingate for my home network but i couldnt really get it working.
First I deployed a connector via docker in a debian VM and after that i deployed it via linux in ubuntu (also a VM) .

-I have a NAS (Truenas Scale) running on
–>I have a resource to that NAS allowing all traffic

-I created a linux VM (ubuntu) running on that NAS on
→ the connector is running on the VM and is getting detected as “connected” on the admin hub.

-I have a phone (android) which has twingate installed and connected. (On that Phone I am not using wifi)

In the Twingate App on the phone the resource gets detected. But if I try connecting to it using a browser it timed out.

I thought it has something to do with the connector and I saw in other conversations, that often the VMs are unable to ping the dedicated resource. In my case I can ping the NAS from the VM and the other way around. From my PC ( I can ping the NAS and the VM and I can also ssh into them.

Any thoughts of how I can fix it?

  • Did you set this up as an address based resource using that ‘home.nas’, or is it IP based and that’s an alias?
  • Is something living at port 80 on the NAS? Or is there a different port for the web UI for Truenas?

That we see the connector has received the request means that everything worked up until that point, and the issue is local between the connector and the resource itself. Pinging might work, but can it resolve that resource using ‘home.nas’, if that’s some sort of local host entry it may be the connector can’t see that, try changing the resource to IP based and test again.

It was IP based and had just an Alias (
First time I created the resource I didnt give it an Alias and it got to the same point, as it also connects to the Connector but not to the resource itself. A couple days later I gave it an Alias and the results were the same. But a couple days after that I only could get to the connector using the Alias. Now if I try connecting using the Alias I get the results as shown above in the picture but if I try connecting using IP I dont get any notification on the admin site, that I even tried connecting. It just doesnt show up. ) It is still IP based but I removed the alias and now I cant get any connection to the connector.

For the VM (where I deployed the connector) I am using Lubuntu and using telnet I can also Ping Port 80 on the NAS

Hey mikadu, I’m taking a look at your configuration in the backend, and I see the definition for the NAS resource is actually set to - note the 169 not the 168.

This is likely the cause of your issues unless you’ve recently changed the IP of your NAS.

Please let us know if updating the resource definition doesn’t change the behaviour!



1 Like

U got to be kidding me. I looked at this for 2 weeks now and i couldn’t figure out what is going on. I feel so dumb xD. Sorry for wasting ur time but thanks for the help.

No judgement, we’ve all been there! Have a great rest of your week!

1 Like