Docker image pull or update failing

Similar but perhaps not the same as

Have been running connector happily for over 12 months and always upgraded when notified to do so. As of about 2 months back I have been unable to update via the simple scripted update or to pull the latest image from docker.

docker returns “manifest for twingate/connector not found”

To troubleshoot I ended up deleting all images and containers, now can’t pull anything current. Interestingly running “docker pull -a twingate/connector” will happily grab 0.10.25 through to 0.33 but nothing else.

I then tried on a couple of RPI’s that I have running docker and they also failed to pull the latest image although error messaging was slightly different (different client versions).

The error I get on RPI is

pull access denied for tiwngate/connector, repository does not exist or may require ‘docker login’: denied: requested access to the resource is denied

I did as it suggested and logged in via ‘docker login’ and go the same result.

Answering my own question, the problem is/was almost certainly the client version. I was using a stock ubuntu (non ce or io docker package) that appears to be quite old. Upgrade to latest ce and problem has resolved.

1 Like