Connecting Windows RDP as a resource

Hi there,

I’m having a few troubles connecting twingate to a windows RDP resource. Currently I have proxmox setup with a Twingate connector on the main linux installation which works just fine for authentication.

I created a virtual machine with windows on it and assigned it an additional ip address from my current hosting provider but here’s the problem. After whitelisting my connector IP address for inbound on 3389 and blocking everything else, it doesn’t let me connect despite being connected to the twingate network.

I’m confused how I will get this additional external IP address to communicate with my proxmox connector IP because those two IP addresses are different. Should I bridge it together or do some VLAN magic?

Hi Tim,

I would highly recommend deploying your Twingate connector as a Proxmox Container as we outline here, as installing it onto the host OS brings with it a few different gotchas which can probably be avoided by using a container instead.

In terms of the RDP connection, as long as the outgoing IP of the Twingate connector host is whitelisted to access 3389 on the Windows host, things should be good.

Looking at the analytics data - I see the connector trying to connect to the IP address specified for the RDP target, and failing to connect.

This usually means 1 of 2 things with RDP:

  1. There’s no actual route between the Connector and the RDP target (can you ping the RDP target IP from the Proxmox host OS successfully?)
  2. Windows RDP access hasn’t actually been enabled on the Windows machine in question. Are you certain remote access is configured?

Let me know!