Can't pull v1.55 with Docker, v1.54 works, can't upgrade

Strange issue. When I try to pull v1.55 (or newer) with docker, like this:

docker pull twingate/connector:1.55

I get the following error:

Pulling repository
Error: Status 410 trying to pull repository twingate/connector: “<html>\r\n<head><title>410 Gone</title></head>\r\n<body>\r\n<center><h1>410 Gone</h1></center>\r\n<hr><center>openresty</center>\r\n</body>\r\n</html>\r\n”

Same thing happens when I use the :latest or :1 tags. Something changed in version 1.55 which results in me no longer being able to pull the docker image for Twingate. I tried contacting Docker and they were less than helpful.

Also to be clear, I can do the “docker pull” with Twingate v1.54, but I can’t pull v1.55 or newer versions.

Hey teckel,

Is your docker client up to date? I found this specific serverfault question that is almost identical to the situation you’re facing.

A few of us have tested internally and are able to pull down latest and 1 and 1.56 fine (1.55 is actually fine to skip as there was an issue in the jump from 54 to 55 that was immediately fixed in 56 - but this will have nothing to do with the issue you’re seeing).

Let me know if everything is updated and you’re still having issues and we can dig a bit deeper.



While the error is the same, the solution and reasons are different. Also, no, the Docker client isn’t up to date nor can it be upgraded as it’s part of an integrated system. Very odd that docker pull twingate/connector:1.54 works, but docker pull twingate/connector:1.55 does not work.

My current “solution” is to do the “docker pull” from another system, export the image, then import it into the system which isn’t allowing me to pull the latest twingate image. Not ideal, but a work-around.