Cannot update Twingate app

We have been using Twingate for about two weeks now and are starting to get notifications that we need to update the app. When we click through the link to update we then get a message that admin credentials are required. We don’t have accounts running with admin privileges as a security measure. I have tried multiple ways to elevate Twingate to run with admin privileges but it fails every time. No matter what method I choose to run as administrator, when I do that the Twingate app reloads the initial screen where I put in my connection string. After I complete that step and attempt to Join Network, I then get a message “You’ll need a new app to open this https link”.

The dialog box with the message in it has an “Ok” button but it is greyed out. I cannot close the dialog box and I cannot get the Twingate app to do anything else when I run as administrator. The only way I have been able to get rid of the dialog box is with a hard restart.

Has anybody had this problem before and found a resolution?