Cannot connect to resource from iPhone

Tested by turning off wifi on iphone which is verified in twingate and going to the url just hangs then cannot load page. How do I troubleshoot?

Any thoughts? I’ve been researching and can’t find an answer.

Welcome to the Community and thank you for reaching out.

Were you able to sign in to the Twingate Client on your iPhone?
Are you able to see your device connected in the Twingate Controller (Admin UI)?
What group is the resource in question assigned to?

Thank you r for responding. I can sign in on iPhone just fine.

I just cannot access the internal ip from the iPhone over cellular. Ex. Open Twingate and log in > copy ip address of NAS and go to browser > paste …. It hangs at 5% and won’t connect throwing connection error eventually.

Device is connected (green light on the NAS and other ip device that is attached). Group is everyone. Security includes iOS and device is verified.
The issue is only with cellular connection. It’s fine when I’m connected to Wi-Fi.

What type of NAS are you trying to connect to?

Raspberry pi with open media vault docker

I have a similar issue. Just starting with Twingate. Trying to connect to a Pi on my internal network from an iPhone. It occasionally passes traffic but nothing consistent. I ran ping tests and typically the failure rate is around 95%. It also shows my Connector swinging between 0s and -55s which is not making sense. I’m setting up another device to see if it makes a difference.

I have the same issue on my IPhone 14 (iOS 16.4.1. - v1.0.29)

It either hangs, or loads for me to try a speedtest via librespeed on my machine and it receives 60 ping,14 jitter. But doesn’t go past 0.01 Mbps and then loses connection.

However, I’ve also tried connecting to my machine on my android (Android 13 - v1.0.26) and it works perfectly. 50 ping, 14 jitter, 50 download, 20 upload.

Seems to be just an IOS issue, which sucks as that’s my daily driver.

Any advice, I’d appreciate it.

I did some further testing,

It appears to be an issue with cellular data only on my IOS device.

Reason I say this is because I’ve tried connecting to another Wi-Fi network (not on my local network) and it works well, I’ve also tried hotspotting on someone else’s mobile network and also worked perfectly, also tried hotspotting from my android device and worked.

Twingate just refuses to work when I’m on my own phones cellular data when trying to connect to my server.

I’m with Voxi (Vodafone) in the UK, not sure if anyone else is on this and whether it’s a network issue with them, or something else that I haven’t figured out yet.

i have reason to believe it’s not an issue with my network provider tho, because I used the same network on my android device which worked perfectly fine, and when hotspotting.

This either means the issue an IOS app bug, or a specific setting on my iPhone.

I highly doubt it’s an issue with my settings on my iPhone, because I’ve tried multiple different settings, enabling them, disabling them, using 3G, 4g, 5g etc to no avail.

I haven’t tried this on a different IOS device (older than the 14 pro) but I will test this next if I get my hand on a different iPhone.

Hopefully we get a reply soon with some additional things I can try from a technician, or if anyone else knows a fix. But I’ll keep you all updated if I figure it out.

Ok… Sorry for the spam lol, but I found the rootcause of the issue I was facing… But no idea how to fix it still, unless I just swap network providers, or phone. :joy:

I tested another network provider Lycamobile (They’re with O2) and it worked flawlessly with Lyca… So it seems the issue is with my IOS Cellular data while using my voxi (vodafone) sim… This still doesn’t make sense to me though, as it works on my android phone, just not my iPhone. Strange.

I also tried out Tailscale with my Voxi sim and that also worked, so I guess twingate just doesn’t like working with vodafone on IOS?

Unless anyone knows why it doesn’t want to work with twingate, I guess ima have to stick with tailscale until I change network providers down the line…

I am having a similar issue with my iPhone 11 over LTE. I tethered to another iphone on the same cellular network (Rogers, Canada) and it works fine via wifi.

I’m hoping that Twingate can resolve this issue as it only affects their client so far.

I am using other VPN clients over LTE on my iphone without any issues.

I also just did a test using an Android phone with the same sim card from my iphone and it works perfectly over LTE with the same carrier (Rogers).

So at this point is seems as though there is an issue with the Twingate iphone client and iphone LTE with certain carriers. I am going to try with another iphone that is on the Bell network later this evening and report back.

1 Like

Nice one, happy to hear I’m not the only one with this issue :sweat_smile: I haven’t been able to try an older iPhone model yet with the same sim as I have no time, but it’s definitely something off happening on the IOS client because it works with other sim providers and on android…

Hopefully the dev team can look through our account logs or something and fix this issue for us and anyone else who might experience this, coz I really want to migrate fully over to Twingate from Tailscale :confused:

OK, did some further testing and I need to revise my earlier findings.

  1. I can actually connect to web resources on my local network with my iphone on my existing carrier (Rogers) over LTE.
  2. I cannot connect to my home automation system over IP using my Crestron app or to my music media server over IP using the provided app
  3. Tested using another iphone that has a dual sim card for Rogers and Bell. I have the same issues on this phone when using LTE for both carriers but the issues disappear when connected to Bell over 5G instead of LTE.

I can’t get a 5G signal for Rogers where I am currently located but will test in another area when possible to see if everything works fine on 5G with Rogers as well.

So far, my issues seem to be related to being on LTE with the iphone but only when trying to establish direct IP connections to servers on my network. I can connect to web servers over various ports on LTE with no issues and I can connect to any server on my network when I tried my Bell connection over 5G.

Also tested with OpenVPN and everything works fine over LTE on the iphone.