Android Client Fails To Log In

Can’t sign into the network with my android phone.

I installed the app from playstore, and clicked sign in.

I signed in, and it said “Signed In” or something, and under
that, “You can now close this window”.

So I exit the browser, and it is not signed in.

I tried using other browsers, I tried uninstalling and
reinstalling the app, and nothing works.

It just shows the checkmark, and then just doesn’t work.

I can see it in the devices tab of the controller though.

Can you help please?


I literally just fixed it.

So, I had created my previous network using my Microsoft account.

And I could not log in as I said before with that account.

I created another network, but this time with my GitHub account.

And it is working fine now!

Also, I don’t know if that helped, but I tried this using my phone on 4G instead of it being connected to the local network where the twingate connector is deployed on.

Hope this helps! :slight_smile:

Thanks, I was using a google account, worked on Mac, not Android. I might revisit at a later time with a different account, for now I have decided to take a different path.